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1. О программном обеспечении DEIF Smart Connect

DEIF Smart Connect - это программное обеспечение для ПК с операционной системой Windows, предназначенное для
настройки контроллеров серии SGC производства компании DEIF.

Утилита позволяет подключать контроллеры серии SGC к ПК при помощи интерфейса USB, что значительно упрощает
конфигурацию устройства: настройку входов/выходов, таймеров, параметров генератора и двигателя.
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2. Инструкция по установке (Installation instructions)

2.1 Системные требования

• Операционная система ПК: Windows 8 или 10 с платформой Microsoft.net 4.0.
• Подключение: Для связи с контроллером используется кабель USB 2.0 тип A-B.

2.2 Установка программного обеспечения DEIF Smart Connect

Порядок установки программного обеспечения DEIF Smart Connect:
1. Перейдите по ссылке на сайт компании DEIF для загрузки программного обеспечения deif.com/software.
2. Из списка выберите программное обеспечение DEIF Smart Connect.
3. Следуйте инструкциям по загрузке.
4. Найдите установочный файл «DEIF-Smart Connect-Setup.zip» на Вашем ПК и распакуйте архив.
5. Двойным щелчком запустите установочный файл «DEIF-Smart Connect-Setup.exe».
6. Появится экран «Приветствие», нажмите «Далее».
7. На экране «Место установки» задайте папку назначения и нажмите «Установить».
8. На экране «Завершение» нажмите «Готово», чтобы завершить установку программы.

2.3 Установка драйвера USB

При подключении контроллера SGC к ПК через USB, будет произведена автоматическая установка драйвера USB.

В некоторых случаях может возникнуть необходимость установки драйвера USB вручную:
1. Подключите контроллер к компьютеру с помощью USB кабеля.

2. Переключите контроллер в режим «Конфигурации» (для этого нажмите кнопки «Стоп» и «Вниз»  одновременно
на три секунды).

3. На дисплее контроллера будет показан экран режима «Конфигурация».

4. При активированном режиме «Конфигурации», перейдите в «Диспетчер устройств Windows Вашего ПК → Порты
(COM & LPT) → SGCSMPL».

5. Щелкните правой кнопкой мыши «SGCSMPL» и выберите «Обновить драйвер».
6. Выберите «Поиск драйвера на этом компьютере».
7. Для 64-битной системы Windows задайте путь к драйверу «C:\Program Files(x86)\DEIF» и затем нажмите «Далее».
8. При успешной установке драйвера USB появляется экран подтверждения - программное обеспечение драйвера успешно

обновлено.
9. Нажмите «Закрыть», чтобы завершить установку драйвера USB.

10. Чтобы выйти из режима «Конфигурации», нажмите кнопки «Вверх» и «Вниз»  одновременно на три секунды.
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3. Применение ПО DEIF Smart Connect

3.1 Подключение к контроллеру

Для подключения к контроллеру:
1. Запустите программное обеспечение DEIF Smart Connect на своем ПК.
2. Подключите ПК к контроллеру при помощи USB кабеля.
3. Установите контроллер в режим «Конфигурации» (см. 2.3 Раздел установка USB драйвера).

Сообщение о состоянии подключения отображается в нижнем левом углу экрана Smart Connect.

Программное обеспечение позволяет открывать, создавать и изменять конфигурации без активного подключения к
контроллеру. Для чтения/записи конфигурации в контроллер требуется активное подключение к устройству.

3.2 Начало работы с ПО DEIF Smart Connect

Запустите программное обеспечение DEIF Smart Connect. После запуска будет возможно создать новую конфигурацию
«Create new configuration» или открыть существующую «Open existing configuration».
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Создание новой конфигурации
Выберите серию контроллеров (например, SGC 1X Series), для которого Вы хотите создать новую конфигурацию и затем
выберите тип контроллера.

Открыть существующую конфигурацию
Ранее созданные конфигурации можно сохранить на ПК (файлы с расширением smc). Нажмите «Browse» для поиска
сохраненного smc файла конфигурации.

Несовместимость
Программа для конфигурации может выдавать сообщение о несовместимости в случаях если:
• Тип контроллера, выбранный в DEIF Smart Connect, отличается от фактически подключенного устройства.
• Версия прошивки контроллера и программы для конфигурации DEIF Smart Connect не соответствуют (например, SGC

R2.0 и DEIF Smart Connect R1.0).

В случае несовместимости утилита DEIF Smart Connect выдает соответствующее сообщение.

The selected product is not compatible with the device detected.
Do you want to continue?

• Выберите «Yes», затем подключите правильный тип контроллера или исправьте несоответствие версий.
• Выберите «No», чтобы закрыть DEIF Smart Connect.

3.3 Меню файл (File)

Конфигурация устройства - это набор значений параметров, которые определяют алгоритм работы контроллера. Все
действия для работы с файлом конфигурации доступны в меню «Файл».

4189341232A UK Страница 6 из 16



• New: Чтобы создать новый файл конфигурации устройства, нажмите «File → New».
• Open: Чтобы открыть ранее сохраненный файл конфигурации устройства, нажмите «File → Open».
• Save: Чтобы сохранить текущую конфигурацию устройства в открытый файл, нажмите «File → Save».
• Save as: Чтобы сохранить текущую конфигурацию устройства в другой файл, нажмите «File → Save as».
• Print: Чтобы распечатать таблицу с настройками параметров контроллера нажмите «File → Print».
• Exit: Чтобы завершить работу с программным обеспечением DEIF Smart Connect нажмите «File → Exit».

Иконки для быстрого доступа к пунктам меню файл «New, Open, Save, Print, Read и Write»
отображаются на экране. Их можно использовать для быстрого доступа к пунктам меню файл.
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4. Меню инструментов (Tools menu)

4.1 Меню инструментов (Tools menu)

С помощью программного обеспечения DEIF Smart Connect можно выполнять ряд действий в дополнение к изменению и
сохранению конфигураций. Эти действия доступны в меню «Инструменты» и активируются при подключении ПК к
контроллеру.

• Write config to device: Чтобы записать конфигурацию в контроллер, нажмите «Tools → Write config to device».
• Read config to device: Чтобы прочитать конфигурацию из контроллера, нажмите «Tools → Read config to device».
• Update firmware on device: Чтобы обновить прошивку контроллера, нажмите «Tools → Update firmware on device».
• Read event log from device: Чтобы прочитать журналы событий из контроллера, нажмите «Tools → Read event log from

device».
• Set date and time on device: Чтобы синхронизировать дату и время в контроллере с ПК, нажмите «Tools → Set date and

time on device».
• Show device info: Чтобы получить подробную информацию о контроллере и программном обеспечении, нажмите «Tools

→ Show device info».
• Update factory profiles: Чтобы обновить заводской профиль настроек контроллера, нажмите «Tools → Update factory

profile».

4.2 Запись конфигурации в устройство

При выборе меню «Write config to device», появится окно с текущими настройками контроллера.
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• Нажмите «Edit Config», чтобы изменить значение любого параметра.
• Нажмите «Save Config To File», чтобы сохранить изменения в файл.
• После завершения изменений конфигурации устройства нажмите «Write To Device», чтобы загрузить новые значения

параметров в контроллер.

При успешной записи новых значений параметров отображается окно подтверждения.

4.3 Чтение конфигурации из устройства

При выборе меню «Read config from device» существующая конфигурация контроллера вычитывается из устройства в DEIF
Smart Connect.

После успешного завершения чтения отображается окно подтверждения.
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4.4 Чтение журнала событий из устройства

Выберите «Read event log from device» читать из устройства для отображения журнала событий подключенного
контроллера.

В журнале показаны последние 100 событий (например, запуск двигателя, остановка двигателя, неисправности и др.), с
меткой времени и информацией о наработке.

Чтобы сохранить журнал событий в формате PDF, нажмите «Save As PDF».

4.5 Установка даты и времени устройства

Выберите меню «Set date and time on device» для синхронизации даты и времени контроллера с Вашим ПК. Перед началом
синхронизации убедитесь, что дата и время на Вашем ПК заданы правильно.

При успешном завершении синхронизации появится окно подтверждения.
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4.6 Информация об устройстве

Выберите меню показать информацию об устройстве «Show device info», чтобы посмотреть информацию о контроллере, его
программном обеспечении и другие сведения.

Контроллер должен находиться в режиме конфигурации, чтобы иметь возможность отображать информацию об устройстве.

Нажимаем кнопки «Стоп» и «Вверх»  одновременно в течение не менее трех секунд, чтобы установить контроллер в
режим «Конфигурации» (см. раздел 2.3 Установка драйвера USB).

Информация об устройстве отобразится в появившемся окне.

4.7 Обновление профилей заводских настроек

При помощи меню «Update factory profile» возможно обновить профили заводских настроек контроллера.
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5. Меню «Справка (Help)»

5.1 Задание режима

При выборе меню «Mode selection» отображается диаграмма доступных режимов контроллера и способов их активации.

Диаграмма выбора режима зависит от типа контроллера. В этом примере показана диаграмма для контроллера SGC 121.

5.2 Информация о программном обеспечении

При выборе пункта меню «About» отображается всплывающее окно с информацией о текущей версии DEIF Smart Connect.
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6. Конфигурируемые параметры

Для каждого отдельного генераторного агрегата необходимо сконфигурировать параметры контроллера (например,
дискретные входы/выходы, параметры генератора и сети, настройки защит и т.д.).

Настройки контроллера разделены на три уровня:

1. Категории параметров:
Каждая категория параметров
имеет собственный набор
настроек.

2. В выбранной категории для
конфигурации доступен свой
ряд параметров.

3. Для параметров возможно
изменять значения и
некоторые свойства.

Дополнительная информация
См. Раздел « Режим конфигурации», «Конфигурируемые параметры» в руководстве пользователя конкретного
типа контроллера для получения дополнительной информации о параметрах.

Пример: Конфигурация параметра
Настройки на экране уровня 2 изменяются вместе с параметром. В этом примере показаны варианты настроек для
параметра Module > Display:

1. Окно настроек параметра уровня 2.
2. Увеличьте/уменьшите значение параметра с помощью

стрелок.
3. Увеличьте/уменьшите значение параметра с помощью

ползунка.
4. Установите флажок, чтобы включить/отключить функцию.
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7. Устранение неисправностей

Неисправность Возможное решение

Драйвер USB не обнаружен. Переустановите драйвер USB, см. раздел 2.3 Установка
драйвера USB.

«Read» и «Write»  значки не отображаются.

Убедитесь, что контроллер находится в режиме
«Конфигурации».
Чтобы войти в режим «Конфигурации», см. раздел 5.2
Выбор режима.

Инструменты для конфигурации  не
доступны.

Убедитесь, что правильный тип контроллера и версия
программного обеспечения выбраны на экране запуска. 

Сообщение:
Error in reading the configuration from the device. Please try
again. Отключите кабель USB, а затем снова его подключите. 
Сообщение:
Cannot communicate with the device. Try re-inserting the USB.

Сообщение:
The selected Product is not compatible with the device detected.
Do you wish to continue?

Смотрите раздел 3.1 Начало работы с ПО DEIF Smart
Config.
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8. Правовая информация

Гарантия
ПРЕДУПРЕЖДЕНИЕ
Вскрытие устройств неуполномоченными лицами категорически запрещено. Несанкционированное вскрытие
устройства в любом случае влечет за собой потерю гарантии.

Изменения
Компания DEIF не несет ответственность за установку и эксплуатацию генераторного агрегата. Все вопросы относительно
порядка монтажа, и эксплуатации управляемого автоматическим блоком генераторного агрегата решаются компанией,
ответственной за монтаж и эксплуатацию генераторного агрегата.

Компания DEIF A/S сохраняет за собой право вносить изменения в настоящую документацию без предварительного
уведомления.

Английская версия этого документа всегда содержит самую актуальную информацию о продукции. Компания DEIF не несет
ответственность за неточности, допущенные при переводе документации. Обновление переведенных документов
осуществляется с задержкой. При обнаружении расхождений в документации необходимо руководствоваться версией
документа на английском.

Авторское право
© Авторское право DEIF A/S 2020. Все права защищены.
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